How to fix this movie requires quicktime which is not supported in this version of itunes

This post will show you how to fix the error ‘this movie requires quicktime which is not supported in this version of itunes’ when you try to play movies in itunes.

If you get this message, then simply open finder, goto applications, right click on itunes and tick the ‘run in 32bit mode’

This error doesnt usually show in later versions of itunes, It happens because the media decoder that you have doesnt have a 64bit version, so it might be worth checking if there is an itunes update available for your platform, to do this just go to itunes > check for updates.

If there is an update install it and you should be fine :)

Tags for How to fix this movie requires quicktime which is not supported in this version of itunes

Error Finder Install Itunes Movie Open Play Quick Time Updates Version